• Announcements

    • Patricia

      Security Certificate   07/21/2017

      It does appear that our security certificate has expired and will have to be updated. These errors occur every time the security certificate has to be updated on the server side, but the server is a hosted server and because of that is quite secure.  Once our technician can install an updated certificate the alert will go away.  You can click past these alerts by choosing "advanced" and then clicking on the link to pandys.org.  You will see a notice in parenthesis telling you this is unsafe in many browsers, but logging on continues to be fine.  The risks in this situation is always that any site without the https designation doing any e-commerce could be collecting your credit card or other data.  The certificates are to protect against that situation.  Currently our e-commerce for membership is suspended until we get the link with Pay Pal working, so data is secure.   I hope this helps ease the fears for logging in in this short-term problem.  Take good care of you! Patricia    

Search the Community



More search options

  • Search By Author

Content Type


Forums

  • The Main Area
  • Public Forums
    • public: wonderful threads
    • public: resources
    • public: essays & articles
  • Administration
    • public: rules, guidelines, and terms of service
    • chat
    • public: questions, suggestions, concerns

Calendars

  • Community Calendar